Support | Zephyr



Test Steps Are Not Cloned In Zephyr For JIRA Cloud-Troubleshooting Tips

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Problem

Test case created by cloning an existing test case with test steps does not have the test steps.

Cause

Multiple reasons like absence of Cloners link or because of issue security scheme. Multiple resolution paths are detailed below. Please follow through them as an Administrator user. After each attempted step, please retry the cloning process.

Resolution

1. Ensure Clone Link Type 'Cloners' exists and has the proper value

Link type can be viewed by adding secure/admin/ViewLinkTypes!default.jspa at the end of the jira host name like below

http://<your JIRA cloud url>/secure/admin/ViewLinkTypes!default.jspa

It should have the below values:
Name                     : Cloners
Outward Description  : clones
Inward Description    : is cloned by

There is a add button to create a new Link type. Please create one if you do not have one by default or use the edit button to set the proper values as mentioned above. This should resolve the issue.

<--Next steps can be verified across projects where you are having cloning issues.-->

2. Check for the Link Issue permission for the  projects that you are trying to clone the test case

Using Jira Administration rights navigate to Administration->Projects->Select your project->Click permissions and check if you have Link issue permissions.

3.This issue also could be because the issue field "Linked Issues" is set up as "hide"

Once this field is marked as 'Show', you should be able to clone the test steps. 
You can find this issue field by navigating to 'Field Configuration'. Refer the link below
https://confluence.atlassian.com/jira/specifying-field-behavior-185729654.html
Note: If you want to remove this field from screen, you can use "screen association", but not "hide". If this field is "hide" you won't  have complete access to it.

4. Ensure your addon permissions are setup as detailed below

Please confirm if the issueType Test is configured to the project in which user is working by going to the "Issue type Scheme" page.
Check the below permissions are assigned respectively. Missing any one of them may lead to unknown issues.

A. Below Addon User Exists: 
=> Navigate to Administration —> User Management and check for the user "addon_com.thed.zephyr.cloud"

B. Group membership for Addon User: The User addon_com.thed.zephyr.cloud should be a member of all the below groups. 
=> atlassian-addons or atlassian-addons-admin 
=> jira-users

C. Global Permission : The group "atlassian-addons-admin" has JIRA Administrators permission 
=> Navigate to Administration -> System -> Security -> Global Permissions
=> Under permissions JIRA Administrators contains atlassian-addons-admin as a group

D. Project Role assigned for the Addon user "addon_com.thed.zephyr.cloud": 
=> Navigate to Administration —> System -> Security -> Roles 
=> Check the role atlassian-addons-project-access Cantains the User - addon_com.thed.zephyr.cloud as a member

E. Project Permission : Add the role to all permissions 
=> Navigate to Administration -> Projects -> <Select any Project> -> Administration -> Permissions

=> Add the role "atlassian-addons-project-access" to all project Permissions

5. Issue Security Scheme

If an issue security scheme has been set up for the projects in question, then look into this scheme and make sure it is not denying permissions to the Add-ons

 


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