Support | Zephyr



Component, Version and Assignee fields are still showing mandatory in Zephyr 4.7

Created on

Problem:

Zephyr prompts to add required fields like Component, Version and Assignee even tough Zephyr 4.7 should not require these fields any longer.

Reason:

This feature is only available for the fresh installation on Zephyr 4.7 and fresh data created on it. Upgraded data will not be having this feature by default.

Fix:

Please run the below query against your MySQL database to make required fields non mandatory as per your requirement.

UPDATE `field_config` SET `mandatory` = b'0' WHERE `id` = '270';

the ID can be one of three numbers:

270 – component 
271 – affectedVersion (for Version) 
273 - assignee

Knowledge Base Document Information:

-----------------------------------------------------------------------------------------------------

Title:Component, Version and Assignee are still showing mandatory in Zephyr 4.7

Product: Zephyr EE/CE

Version: 4.7

Summary: An SQL query has to run against the upgraded data to make the fields non mandatory.


------------------------------------------------------------------------------------------------------


Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request
Powered by Zendesk