Support | Zephyr



Custom Link Type is Non-Functional or Non-Existent After Upgrade to Zephyr for JIRA Cloud 1.6

Created on

Problem

After upgrading Zephyr for JIRA Cloud to version 1.6, your custom link type that you created seems to no longer exist or you receive an error when you try to add defects to test executions. 

Cause

We've added a new feature to Zephyr for JIRA Cloud in version 1.6 that allows users to change the link type from "Relates" to others like "Blocker" or "Clones" or a custom type. 

Workaround

We're working on a better way to handle custom link types for the next version. In the meantime, don't be alarmed if this happens to you. You can still re-set your custom link type from Zephyr for JIRA Cloud's administration page in Administration > Add-ons > Manage Add-ons > Zephyr > General Configuration. From that page, set your link type again.

Note: The UI may not display much information while the link type is being set. If you have a lot of executions, this may take some time. Do not refresh the page or close your browser after you reset your link type. While the UI doesn't display much in the way of useful information, it is still actively working. This is also something we're going to improve upon in version 1.7.

If you use the standard link type "Relates," this won't be an issue for you.


Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request
Powered by Zendesk