Support | Zephyr



Folder Structure missing for Testcase Execution and deleting a node in TCE and TCR is throwing an error

Created on

Problem

Folder Structure missing for Testcase Execution and deleting a node in TCE and TCR is throwing an error 

Cause

Bulk Assignment to Anyone in Testcase EAS application

Fix

For a quick troubleshooting please check if the testcases are present in your database using the following query,

SELECT * FROM `cycle` WHERE release_id =13;

SELECT * FROM `release_test_schedule` WHERE cycle_catalog_id IN
(SELECT id FROM `cycle_catalog_map` WHERE cycle_id IN
(SELECT id FROM `cycle` WHERE release_id = 13))
AND tester_id=-10
;

SELECT COUNT(*), tester_id FROM release_test_schedule GROUP BY tester_id;

If the test cases are present , then please apply the following steps to see your test cases in the UI

        1)Stop Zephyr service on the Zephyr server

        2) Log into MySQL (by default the username and password are root ) and use     the command:

  • mysql>  insert into`preference`(`name`,`value`,`default_value`,`is_customizable`) values ('tce.loadAllSchedules.VALUE','false','false','');
    3) Start Zephyr service

Additionally the above solution is also valid for the issue where a user gets the following attached error (Zephyr_Error_Deleting_Test_Cases.JPG) when deleting the node in the Test Case Execution and TCR application.

As by default zephyr pre- loads the test cases assigned to that particular user along with test cases assigned to anyone in that release .In case where there are more than 10,000 testcases, these large fetches will increase load on the memory cache which will put the database in bad condition.

Zephyr can be configured so that testcases won't be pre-loaded to the testcase execution tree as soon as the user tries to access the TCE Application. Instead the testcases will be loaded only when the user clicks on a particular node. To configure this, the above query is applied

 

 

Knowledge Base Document Information:

---------------------------------------------------------------------------------------------------------------------------

Title:Folder Structure missing for Testcase Execution

Product: Zephyr Enterprise/Community Edition

Version: All

Summary: The error persists due to Bulk Assignment of Testcases

------------------------------------------------------------------------------------------------------------------------

 


Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request
Powered by Zendesk