Support | Zephyr



How to capture a thread dump

Created on

Problem

Zephyr's threads are causing an issue on the server.

Cause

A thread dump can help troubleshoot certain specific issues happening in a service such as Zephyr and are sometimes required for troubleshooting issues

Fix

During an issue occurrence (before the machine is restarted), please take the time to capture the thread dump by:

1) Get the process ID of the tomcat service (Task Manager in Windows does this)

2) Download and extract 'pstools' from http://technet.microsoft.com/en-us/sysinternals/bb896649.aspx and place it in a local folder (ie C:\pstools)

3) As an Administrator user, Run:

C:\pstools\PsExec -s %PATH_TO_JDK%\bin\jstack.exe -l <Tomcat_Process_Id> > threaddump.txt

Email support the thread dump if requested.

 

 

Knowledge Document Information

 

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Title:                      How to capture a thread dump

Product:                 Enterprise Edition, Community Edition

Version:                 All

Summary:              Support may request thread dumps, this is how they are performed                                            and at what times 

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