Support | Zephyr



Error : importProvider

Created on

Issue :

While trying to import Requirements into Zephyr Enterprise Edition receiving the following error as in the screenshot and the below exception in the logs

null id in com.thed.model.RequirementTree entry (don't flush the Session after an exception occurs)

Cause :

Chances are that you have installed Zephyr or the Database (MySQL) in AWS or you are using Amazon RDS.

Please check the flag value of below query. It should be OFF.

Actually when MySQL is installed in normal OSs like Unix or Windows this particular parameter " explicit_defaults_for_timestamp" will be OFF but because of AWS's configuration settings MySQL installed in AWS makes this parameter value change to ON.

show variables like 'explicit_defaults_for_timestamp';

If any value other than OFF or no value , you need too change the value as mentioned by the steps in the "Fix" given below

Fix:

For local mysql this property can be modified in my.cnf in the [mysqld] section as mentioned below.

explicit_defaults_for_timestamp = 1

The value should be changed to 0 ie

explicit_defaults_for_timestamp = 0
After saving the changes in the my.cnf file kindly restart the database.
If mysql installed in RDS change the values via the console as in the screenshot below


Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request
Powered by Zendesk